handphone.my.id

review xiaomi 2021

Masirvan.my.id

Mikrotik melangkah di depan sebuah jaringan secara fisik atau virtual. Saat ini, Mikrotik tersedia dalam versi awan yang bernama Mikrotik CHR. Sistem operasi ini memungkinkan kamu untuk menginstal Mikrotik CHR pada VPS atau server yang kamu miliki. Di artikel ini, kamu akan belajar bagaimana cara meng-Install Mikrotik CHR di CentOS 8.

Mikrotik CHR

Mikrotik Cloud Hosted Router atau disingkat Mikrotik CHR adalah versi RouterOS yang didesain khusus agar sebuah perangkat komputer dapat dijalankan secara virtual di Virtual Machine (VM). CHR menggunakan arsitektur x86 64-bit dan dapat digunakan pada sebagian besar hypervisor, seperti VMWare, HyperV, atau VirtualBox.

Mikrotik CHR sama seperti RouterOS biasanya, kecuali level lisensinya. Tapi tenang saja, kita tetap bisa menggunakan CHR dengan lisensi gratis, walaupun kecepatan lalu lintas dengan lisensi gratis hanya akan dibatas pada 1 Mbit per antarmuka.

Baca Juga: Cara Instalasi VirtualBox di CentOS 7

Cara Install Mikrotik CHR di CentOS 8

Berikut ini adalah cara Install Mikrotik CHR untuk VPS dengan sistem operasi CentOS 7. Tapi sebelum itu, kamu sudah siapkan beberapa hal berikut:

Langkah instalasi:

  • Perbarui Server
  • Pasang Firewall
  • Unduh Mikrotik CHR
  • Gunung Mikrotik CHR
  • Unduh Winbox
  • Menguji

Berikut ini adalah penjelasan dari langkah instalasi di atas.

Perbarui Server

Pertama, terlebih dahulu terlebih dahulu apakah server sudah siap, orangtua adalah agar paket yang akan digunakan ikut serta. Kemudian lakukan reboot server.

$ yum update -y

$ reboot

Pasang Firewall

Firewall yang digunakan dalam cara Install Mikrotik di CentOS 8 ini adalah CSF (ConfigServer Security & Firewall). Instalasi CSF Firewall di CentOS 8 sedikit berbeda dengan OS lain.

$ cd /usr/src

$ wget https://download.configserver.com/csf.tgz 

$ tar -xzf csf.tgz

Instal & Buat direktori iptables

$ yum install iptables-services -y

$ touch /etc/sysconfig/iptables

$ touch /etc/sysconfig/iptables6

Instal CSF

$ csf csf/

$ install.sh

$ perl /usr/local/csf/bin/csftest.pl

Edit csf.conf lalu ubah nilai make PENGUJIAN menjadi 0.

$ nano /etc/csf/csf.conf

make TESTING=’0’

Setelah itu simpan dan keluar. Kemudian, memuat ulang CSF dengan perintah berikut.

$ csf -r

Unduh Mikrotik CHR

Install beberapa paket yang dibutuhkan untuk keperluan instalasi Mikrotik CHR di CentOS 8 ini, kemudian unduh paket Mikrotik CHR dengan pilihan Raw Disk Image, di sini kami menggunakan versi yang sudah stabil, yaitu v6.47.6.

$ yum install wget unzip -y

$ wget https://download.mikrotik.com/routeros/6.47.6/chr-6.47.6.img.zip -O mik-chr.img.zip

Perintah di atas berarti kamu akan mengunduh menggunakan wget dan save dengan nama mik-chr-.img.zip. Jika sudah terunduh, buka zip atau ekstrak mengajukan .zip tersebut dan daftar.

$ unzip mik-chr.img.zip

$  ls 

chr-6.47.6.img  mik-chr.img.zip

Artinya proses buka zip sudah selesai.

Gunung Mikrotik CHR

Lakukan meningkat pada mengajukan chr-xxxx.img ke direktori / mnt dengan perintah di bawah ini.

$ mount -o loop,offset=512 chr-xxxx.img /mnt

Sesuaikan nama “xxxx” dengan mengajukan CHR yang kamu miliki. Kemudian, verifikasikan hasil meningkat yang dilakukan tadi dengan perintah berikut ini.

$ ls /mnt

bin  boot  dev  lost+found  nova  rw  SHOW_LICENSE  UPGRADED  var

Setelah itu, buat sejumlah perintah pada CLI untuk membina menangani dari alamat IP pada antarmuka ether1, rute default, dan DNS server dari Mikrotik CHR yang dapat dieksekusi dengan perintah gema. Kemudian sejumlah perintah tersebut akan disimpan dalam file autorun.scr yang terdapat pada direktori / mnt / rw /. Perintahnya akan terlihat seperti di bawah ini.

$ ADDRESS=`ip addr show eth0 | grep global | cut -d' ' -f 6 | head -n 1` && 

GATEWAY=`ip route list | grep default | cut -d' ' -f 3` && 

echo "/ip address add address=$ADDRESS interface=[/interface ethernet find where name=ether1]

/ip route add gateway=$GATEWAY

/ip dns set servers=8.8.8.8,8.8.4.4" > /mnt/rw/autorun.scr

Verifikasikan apakah perintah-perintah tersebut sudah tertulis di dalam mengajukan autorun.scr atau belum.

$ cat /mnt/rw/autorun.scr

/ip address add address=103.xxx interface=[/interface ethernet find where name=ether1] 

/ip route add gateway=103.xxx

/ip dns set servers=8.8.8.8,8.8.4.4

Alamat bagian = 103.xxx ini diharapkan sesuai dengan alamat IP di VPS kamu. Diberi proses pemasangan sudah selesai, maka kamu bisa melepas meningkat (unmout) dengan perintah:

$ echo u > /proc/sysrq-trigger

Kemudian salin seluruh isi dan berkas dari gambar chr tadi ke / dev / vda menggunakan perintah dd (disk dump) seperti di bawah ini.

$ dd if=chr-6.47.6.img bs=1024 of=/dev/vda

65536+0 records in

65536+0 records out

67108864 bytes (67 MB, 64 MiB) copied, 4.20313 s, 16.0 MB/s

Sesuaikan versi CHR dengan mengajukan yang kamu unduh tadi menggunakan perintah wget. Kemudian reboot VPS menggunakan perintah reboot.

$ reboot

Buka Konsol

Kamu tidak dapat menghubungkan Mikrotik dengan SSH secara manual dari prompt perintah maupun terminal. Jadi kamu membutuhkan Console Client Area di provider VPS kamu. Misalnya di Dewaweb, langkahnya akan seperti berikut ini:

Area Klien -> Kelola Layanan -> Pilih Server / VPS-nya -> Buka Konsol.

mikrotik 6.47.6 versi stabil

Secara default, Mikrotik menggunakan nama pengguna Admin dan kata sandi-nya dikosongkan (atau langsung klik Enter saja).

Gambar di atas menunjukkan bahwa Mikrotik CHR telah berhasilInstall di VPS. Selanjutnya kamu bisa membuat koneksi menggunakan aplikasi Winbox.

Unduh Winbox

Usai reboot, VPS akan mulai kembali secara otomatis. Proses selanjutnya adalah kamu perlu mengunduh perangkat lunak atau aplikasi Winbox, yaitu perangkat lunak atau aplikasi untuk melakukan koneksi ke Mikrotik.

Baca Juga: Cara Instal Moodle di VPS Ubuntu 18.04

Menguji

Jika sudah terunduh, buka Winbox dan isi datanya sesuai dengan keperluanmu:

Terhubung ke: (identitas IP Address VPS kamu)

Gabung: admin

Kata sandi: (kosongkan)

Kamu bisa mengosongkan bagian kata sandi, karena secara default Mikrotik tidak menggunakan kata sandi, melainkan hanya nama pengguna untuk login saja. Setelah selesai, klik “Connect” dan bantu akan seperti gambar di bawah ini.

instal mikrotik chr pengujian sukses

Jika sudah menjadi seperti di atas, maka cara Install Mikrotik CHR pada CentOS 8 sudah selesai.

Baca Juga: Cara Install Moodle di VPS CentOS 7

Simpulan

Mikrotik CHR sama seperti Mikrotik RouterOS pada umumnya, hanya saja CHR tidak di-Install langsung di sisi perangkat komputer, melainkan secara virtual di VPS server dengan cara seperti di atas. Setelah disambungkan, kamu perlu mengubahnya sesuai kebutuhanmu, terlebih dahulu di bagian informasi login yang bisa memengaruhi koneksi internetmu.

Namun, satu hal yang perlu kamu ingat, ketika memilih VPS, jika kamu menggunakan layanan yang terpercaya, misalnya Dewaweb. Selain karena selalu dapat diandalkan, kecepatan dan keamanan yang kamu dapatkan tak lagi menjadi masalah. Demikian artikel tentang cara Install Mikrotik CHR di CentOS 8 ini. Semoga artikel ini membantu, salam sukses online!



fotografer indonesia

Leave a Reply

Your email address will not be published. Required fields are marked *